#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?|(?:\G(?!\A)(?<=\|)|^\|\h*\[x\]\h*\|)\h*\K([^|\n]+)(?<=\S)\h*\||\[x]\h*\K([^|\s!]+(?:\h*[^|\s]+)*))|" & @CRLF & _
"(?|(?:\G(?!\A)\||^\|\h*\[x]\h*!\h*\|)\h*\K([^|\n]+)(?<=\S)\h*|\[x]\h*!\h*\K([^|\s]+(?:\h*[^|\s]+)*))"
Local $sString = "Test cases where it should match." & @CRLF & _
"- [x] Example task. | Task ends. [x] Another task." & @CRLF & _
"- [x] ! Example task. | This ends. [x] ! Another task." & @CRLF & _
"- [x] Example task! | Task ends. [x] Another task!" & @CRLF & _
"- [x] ! Example task! | This ends. [x] ! Another task!" & @CRLF & _
"" & @CRLF & _
"This is a sentence. [x] Task is here." & @CRLF & _
"Other text. Another [x] ! Task is here." & @CRLF & _
"" & @CRLF & _
"Must not match in the table." & @CRLF & _
"| | Task name | Plan | Actual | File |" & @CRLF & _
"| :---- | :-------------| :---------: | :---------: | :------------: |" & @CRLF & _
"| [x] | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |" & @CRLF & _
"| [x] ! | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |" & @CRLF & _
"" & @CRLF & _
"Groups expected:" & @CRLF & _
"$1: all text after [x]" & @CRLF & _
"$2: all text after [x] !" & @CRLF & _
"" & @CRLF & _
"Regex for each group:" & @CRLF & _
"$1: [^\|\s]\s*\[x\]\s*\K[^!|\n]*" & @CRLF & _
"$2: [^\|\s]\s*\[x\]\s*\!\s*\K[^|\n]*" & @CRLF & _
"" & @CRLF & _
"With the not-capturing group applied:" & @CRLF & _
"$1: (?:[^\|\s]\s*\[x\]\s*\K[^!|\n]*)" & @CRLF & _
"$2: (?:[^\|\s]\s*\[x\]\s*\!\s*\K[^|\n]*)" & @CRLF & _
"" & @CRLF & _
"The combined expression:" & @CRLF & _
"(?:[^\|\s]\s*\[x\]\s*\K([^!|\n]*))|(?:[^\|\s]\s*\[x\]\s*\!\s*\K([^|\n]*))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")