import re
regex = re.compile(r"""
(?|(?:\G(?!\A)(?<=\|)|^\|\h*\[x\]\h*\|)\h*\K([^|\n]+)(?<=\S)\h*\||\[x]\h*\K([^|\s!]+(?:\h*[^|\s]+)*))|
(?|(?:\G(?!\A)\||^\|\h*\[x]\h*!\h*\|)\h*\K([^|\n]+)(?<=\S)\h*|\[x]\h*!\h*\K([^|\s]+(?:\h*[^|\s]+)*))
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("Test cases where it should match.\n"
"- [x] Example task. | Task ends. [x] Another task.\n"
"- [x] ! Example task. | This ends. [x] ! Another task.\n"
"- [x] Example task! | Task ends. [x] Another task!\n"
"- [x] ! Example task! | This ends. [x] ! Another task!\n\n"
"This is a sentence. [x] Task is here.\n"
"Other text. Another [x] ! Task is here.\n\n"
"Must not match in the table.\n"
"| | Task name | Plan | Actual | File |\n"
"| :---- | :-------------| :---------: | :---------: | :------------: |\n"
"| [x] | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |\n"
"| [x] ! | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |\n\n"
"Groups expected:\n"
"$1: all text after [x]\n"
"$2: all text after [x] !\n\n"
"Regex for each group:\n"
"$1: [^\\|\\s]\\s*\\[x\\]\\s*\\K[^!|\\n]*\n"
"$2: [^\\|\\s]\\s*\\[x\\]\\s*\\!\\s*\\K[^|\\n]*\n\n"
"With the not-capturing group applied:\n"
"$1: (?:[^\\|\\s]\\s*\\[x\\]\\s*\\K[^!|\\n]*)\n"
"$2: (?:[^\\|\\s]\\s*\\[x\\]\\s*\\!\\s*\\K[^|\\n]*)\n\n"
"The combined expression:\n"
"(?:[^\\|\\s]\\s*\\[x\\]\\s*\\K([^!|\\n]*))|(?:[^\\|\\s]\\s*\\[x\\]\\s*\\!\\s*\\K([^|\\n]*))")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")