using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?|(?:\G(?!\A)(?<=\|)|^\|\h*\[x\]\h*\|)\h*\K([^|\n]+)(?<=\S)\h*\||\[x]\h*\K([^|\s!]+(?:\h*[^|\s]+)*))|
(?|(?:\G(?!\A)\||^\|\h*\[x]\h*!\h*\|)\h*\K([^|\n]+)(?<=\S)\h*|\[x]\h*!\h*\K([^|\s]+(?:\h*[^|\s]+)*))";
string input = @"Test cases where it should match.
- [x] Example task. | Task ends. [x] Another task.
- [x] ! Example task. | This ends. [x] ! Another task.
- [x] Example task! | Task ends. [x] Another task!
- [x] ! Example task! | This ends. [x] ! Another task!
This is a sentence. [x] Task is here.
Other text. Another [x] ! Task is here.
Must not match in the table.
| | Task name | Plan | Actual | File |
| :---- | :-------------| :---------: | :---------: | :------------: |
| [x] | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |
| [x] ! | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |
Groups expected:
$1: all text after [x]
$2: all text after [x] !
Regex for each group:
$1: [^\|\s]\s*\[x\]\s*\K[^!|\n]*
$2: [^\|\s]\s*\[x\]\s*\!\s*\K[^|\n]*
With the not-capturing group applied:
$1: (?:[^\|\s]\s*\[x\]\s*\K[^!|\n]*)
$2: (?:[^\|\s]\s*\[x\]\s*\!\s*\K[^|\n]*)
The combined expression:
(?:[^\|\s]\s*\[x\]\s*\K([^!|\n]*))|(?:[^\|\s]\s*\[x\]\s*\!\s*\K([^|\n]*))";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}