import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?|(?:\\G(?!\\A)(?<=\\|)|^\\|\\h*\\[x\\]\\h*\\|)\\h*\\K([^|\\n]+)(?<=\\S)\\h*\\||\\[x]\\h*\\K([^|\\s!]+(?:\\h*[^|\\s]+)*))|\n"
+ "(?|(?:\\G(?!\\A)\\||^\\|\\h*\\[x]\\h*!\\h*\\|)\\h*\\K([^|\\n]+)(?<=\\S)\\h*|\\[x]\\h*!\\h*\\K([^|\\s]+(?:\\h*[^|\\s]+)*))";
final String string = "Test cases where it should match.\n"
+ "- [x] Example task. | Task ends. [x] Another task.\n"
+ "- [x] ! Example task. | This ends. [x] ! Another task.\n"
+ "- [x] Example task! | Task ends. [x] Another task!\n"
+ "- [x] ! Example task! | This ends. [x] ! Another task!\n\n"
+ "This is a sentence. [x] Task is here.\n"
+ "Other text. Another [x] ! Task is here.\n\n"
+ "Must not match in the table.\n"
+ "| | Task name | Plan | Actual | File |\n"
+ "| :---- | :-------------| :---------: | :---------: | :------------: |\n"
+ "| [x] | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |\n"
+ "| [x] ! | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |\n\n"
+ "Groups expected:\n"
+ "$1: all text after [x]\n"
+ "$2: all text after [x] !\n\n"
+ "Regex for each group:\n"
+ "$1: [^\\|\\s]\\s*\\[x\\]\\s*\\K[^!|\\n]*\n"
+ "$2: [^\\|\\s]\\s*\\[x\\]\\s*\\!\\s*\\K[^|\\n]*\n\n"
+ "With the not-capturing group applied:\n"
+ "$1: (?:[^\\|\\s]\\s*\\[x\\]\\s*\\K[^!|\\n]*)\n"
+ "$2: (?:[^\\|\\s]\\s*\\[x\\]\\s*\\!\\s*\\K[^|\\n]*)\n\n"
+ "The combined expression:\n"
+ "(?:[^\\|\\s]\\s*\\[x\\]\\s*\\K([^!|\\n]*))|(?:[^\\|\\s]\\s*\\[x\\]\\s*\\!\\s*\\K([^|\\n]*))";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}