#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z][A-Za-z0-9][0-9]{7}$"
Local $sString = "ab1234567" & @CRLF & _
"AB1234567" & @CRLF & _
"a12345678" & @CRLF & _
"AB12345678" & @CRLF & _
"aB123456" & @CRLF & _
"abc123456" & @CRLF & _
"abcdefghi" & @CRLF & _
"1b2345678"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")