re = /^[A-Za-z][A-Za-z0-9][0-9]{7}$/m
str = 'ab1234567
AB1234567
a12345678
AB12345678
aB123456
abc123456
abcdefghi
1b2345678'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end