using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-z][A-Za-z0-9][0-9]{7}$";
string input = @"ab1234567
AB1234567
a12345678
AB12345678
aB123456
abc123456
abcdefghi
1b2345678";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}