package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z][A-Za-z0-9][0-9]{7}$`)
var str = `ab1234567
AB1234567
a12345678
AB12345678
aB123456
abc123456
abcdefghi
1b2345678`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}