#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^\p{Han}]*?)(?:\s+([\p{Han}].*))?$"
Local $sString = "Companyaaaaaaaa. 有限公司有限公司有限公司" & @CRLF & _
"Companybbbbbb (asdasd) xxx 有限公司有限公司有限公司" & @CRLF & _
"Companyccccccccccc (cccc) Co., Ltd. 有限公司有限公司(集团)有限公司" & @CRLF & _
"CompanyD aaa ccc. Ltd." & @CRLF & _
"CompanyE Capital ccccc Co., Ltd." & @CRLF & _
"GroupF Capital asddddc Limited 有限公司有限公司有限公司(有限公司)" & @CRLF & _
"HoldingG Group (dasdddddq) Limited 有限公司有限公司" & @CRLF & _
"HoldingH asddc axcaCasd 有限公司/ 有限公司" & @CRLF & _
"GroupI Capital 有限公司集团" & @CRLF & _
"CaptialI Capital 有限公司" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")