import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\\p{Han}]*?)(?:\\s+([\\p{Han}].*))?$";
final String string = "Companyaaaaaaaa. 有限公司有限公司有限公司\n"
+ "Companybbbbbb (asdasd) xxx 有限公司有限公司有限公司\n"
+ "Companyccccccccccc (cccc) Co., Ltd. 有限公司有限公司(集团)有限公司\n"
+ "CompanyD aaa ccc. Ltd.\n"
+ "CompanyE Capital ccccc Co., Ltd.\n"
+ "GroupF Capital asddddc Limited 有限公司有限公司有限公司(有限公司)\n"
+ "HoldingG Group (dasdddddq) Limited 有限公司有限公司\n"
+ "HoldingH asddc axcaCasd 有限公司/ 有限公司\n"
+ "GroupI Capital 有限公司集团\n"
+ "CaptialI Capital 有限公司\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}