$re = '/^([^\p{Han}]*?)(?:\s+([\p{Han}].*))?$/m';
$str = 'Companyaaaaaaaa. 有限公司有限公司有限公司
Companybbbbbb (asdasd) xxx 有限公司有限公司有限公司
Companyccccccccccc (cccc) Co., Ltd. 有限公司有限公司(集团)有限公司
CompanyD aaa ccc. Ltd.
CompanyE Capital ccccc Co., Ltd.
GroupF Capital asddddc Limited 有限公司有限公司有限公司(有限公司)
HoldingG Group (dasdddddq) Limited 有限公司有限公司
HoldingH asddc axcaCasd 有限公司/ 有限公司
GroupI Capital 有限公司集团
CaptialI Capital 有限公司
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);