import Foundation
let pattern = #"^([^\p{Han}]*?)(?:\s+([\p{Han}].*))?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Companyaaaaaaaa. 有限公司有限公司有限公司
Companybbbbbb (asdasd) xxx 有限公司有限公司有限公司
Companyccccccccccc (cccc) Co., Ltd. 有限公司有限公司(集团)有限公司
CompanyD aaa ccc. Ltd.
CompanyE Capital ccccc Co., Ltd.
GroupF Capital asddddc Limited 有限公司有限公司有限公司(有限公司)
HoldingG Group (dasdddddq) Limited 有限公司有限公司
HoldingH asddc axcaCasd 有限公司/ 有限公司
GroupI Capital 有限公司集团
CaptialI Capital 有限公司
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)