using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{start}((?:(?:(?!{(?:start|end)}).)+|(?R))*){end}";
string input = @"{start} SubPa{1}ttern1 {end}
....
{start} SubPattern2 {end}
....
{start} {start}SubPattern3{end} {end}
{start}{start} {start}SubPattern3{end} {end}{end}
{start}SubPattern1{end}{start}SubPattern2{end}{start}{start}SubPattern3{end}{end}
{start} SubPattern1 {end}
{start} SubPattern2 {end}
{start} {start}SubPattern3{end} {end}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}