import Foundation
let pattern = #"{start}((?:(?:(?!{(?:start|end)}).)+|(?R))*){end}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{start} SubPa{1}ttern1 {end}
....
{start} SubPattern2 {end}
....
{start} {start}SubPattern3{end} {end}
{start}{start} {start}SubPattern3{end} {end}{end}
{start}SubPattern1{end}{start}SubPattern2{end}{start}{start}SubPattern3{end}{end}
{start} SubPattern1 {end}
{start} SubPattern2 {end}
{start} {start}SubPattern3{end} {end}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)