const regex = /{start}((?:(?:(?!{(?:start|end)}).)+|(?R))*){end}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{start}((?:(?:(?!{(?:start|end)}).)+|(?R))*){end}', 'gm')
const str = `{start} SubPa{1}ttern1 {end}
....
{start} SubPattern2 {end}
....
{start} {start}SubPattern3{end} {end}
{start}{start} {start}SubPattern3{end} {end}{end}
{start}SubPattern1{end}{start}SubPattern2{end}{start}{start}SubPattern3{end}{end}
{start} SubPattern1 {end}
{start} SubPattern2 {end}
{start} {start}SubPattern3{end} {end}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}