$re = '/{start}((?:(?:(?!{(?:start|end)}).)+|(?R))*){end}/m';
$str = '{start} SubPa{1}ttern1 {end}
....
{start} SubPattern2 {end}
....
{start} {start}SubPattern3{end} {end}
{start}{start} {start}SubPattern3{end} {end}{end}
{start}SubPattern1{end}{start}SubPattern2{end}{start}{start}SubPattern3{end}{end}
{start} SubPattern1 {end}
{start} SubPattern2 {end}
{start} {start}SubPattern3{end} {end}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);