#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^\w{3,16}$"
Local $sString = "awesome" & @CRLF & _
"1232443242" & @CRLF & _
"34" & @CRLF & _
"45453.54" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"3342" & @CRLF & _
"43543" & @CRLF & _
".co" & @CRLF & _
"coo" & @CRLF & _
"niceee" & @CRLF & _
"minecraftGamer23" & @CRLF & _
"co" & @CRLF & _
"_nicelol23__" & @CRLF & _
"T_T" & @CRLF & _
"1.2e3" & @CRLF & _
"awo!d" & @CRLF & _
"awesome"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")