using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w{3,16}$";
string input = @"awesome
1232443242
34
45453.54
1
2
3342
43543
.co
coo
niceee
minecraftGamer23
co
_nicelol23__
T_T
1.2e3
awo!d
awesome";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}