package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^\w{3,16}$`)
var str = `awesome
1232443242
34
45453.54
1
2
3342
43543
.co
coo
niceee
minecraftGamer23
co
_nicelol23__
T_T
1.2e3
awo!d
awesome`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}