using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https:\/\/(((www|staging)\.fanball\.com\/lobby\/?(\?.*)?$)|fanball-qa\.shub\.dog\/lobby\/?(\?.*)?$)";
string input = @"https://www.fanball.com/
https://www.fanball.com/lobby
https://www.fanball.com/lobby/
https://www.fanball.com/lobby/blah
https://www.fanball.com/lobby/?foo=bar
https://staging.fanball.com/
https://staging.fanball.com/lobby
https://staging.fanball.com/lobby/
https://staging.fanball.com/lobby/blah
https://staging.fanball.com/lobby/?foo=bar
https://fanball-qa.shub.dog/
https://fanball-qa.shub.dog/lobby
https://fanball-qa.shub.dog/lobby/
https://fanball-qa.shub.dog/lobby/blah
https://fanball-qa.shub.dog/lobby/?foo=bar";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}