import re
regex = re.compile(r"^https:\/\/(((www|staging)\.fanball\.com\/lobby\/?(\?.*)?$)|fanball-qa\.shub\.dog\/lobby\/?(\?.*)?$)", flags=re.MULTILINE)
test_str = ("https://www.fanball.com/\n"
"https://www.fanball.com/lobby\n"
"https://www.fanball.com/lobby/\n"
"https://www.fanball.com/lobby/blah\n"
"https://www.fanball.com/lobby/?foo=bar\n"
"https://staging.fanball.com/\n"
"https://staging.fanball.com/lobby\n"
"https://staging.fanball.com/lobby/\n"
"https://staging.fanball.com/lobby/blah\n"
"https://staging.fanball.com/lobby/?foo=bar\n"
"https://fanball-qa.shub.dog/\n"
"https://fanball-qa.shub.dog/lobby\n"
"https://fanball-qa.shub.dog/lobby/\n"
"https://fanball-qa.shub.dog/lobby/blah\n"
"https://fanball-qa.shub.dog/lobby/?foo=bar")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")