package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https:\/\/(((www|staging)\.fanball\.com\/lobby\/?(\?.*)?$)|fanball-qa\.shub\.dog\/lobby\/?(\?.*)?$)`)
var str = `https://www.fanball.com/
https://www.fanball.com/lobby
https://www.fanball.com/lobby/
https://www.fanball.com/lobby/blah
https://www.fanball.com/lobby/?foo=bar
https://staging.fanball.com/
https://staging.fanball.com/lobby
https://staging.fanball.com/lobby/
https://staging.fanball.com/lobby/blah
https://staging.fanball.com/lobby/?foo=bar
https://fanball-qa.shub.dog/
https://fanball-qa.shub.dog/lobby
https://fanball-qa.shub.dog/lobby/
https://fanball-qa.shub.dog/lobby/blah
https://fanball-qa.shub.dog/lobby/?foo=bar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}