#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d\s\'(?<Event_type>[^\']+)\]\s"
Local $sString = "Message=The Virtual Machine Management service initiated the live migration of virtual machine 'PR-PAY-02' to destination host 'DC2-T2-CH02' (VMID 19576828-2B68-4B58-8726-AB00A79111A3)."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")