use strict;
my $str = 'Message=The Virtual Machine Management service initiated the live migration of virtual machine \'PR-PAY-02\' to destination host \'DC2-T2-CH02\' (VMID 19576828-2B68-4B58-8726-AB00A79111A3).';
my $regex = qr/\d\s\'(?<Event_type>[^\']+)\]\s/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}