// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\d\s\'(?<Event_type>[^\']+)\]\s").unwrap();
let string = "Message=The Virtual Machine Management service initiated the live migration of virtual machine 'PR-PAY-02' to destination host 'DC2-T2-CH02' (VMID 19576828-2B68-4B58-8726-AB00A79111A3).";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}