const regex = /\d\s\'(?<Event_type>[^\']+)\]\s/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d\\s\\\'(?<Event_type>[^\\\']+)\\]\\s', 'g')
const str = `Message=The Virtual Machine Management service initiated the live migration of virtual machine 'PR-PAY-02' to destination host 'DC2-T2-CH02' (VMID 19576828-2B68-4B58-8726-AB00A79111A3).`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}