#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)START" & @CRLF & _
"(?:" & @CRLF & _
" (?: cat dog bird ) | " & @CRLF & _
" (?: cat | dog | bird )" & @CRLF & _
")" & @CRLF & _
"END"
Local $sString = "STARTcatdogbirdEND" & @CRLF & _
"STARTcatEND" & @CRLF & _
"STARTdogEND" & @CRLF & _
"STARTbirdEND" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")