$re = '/START
(?:
(?: cat dog bird ) |
(?: cat | dog | bird )
)
END/mx';
$str = 'STARTcatdogbirdEND
STARTcatEND
STARTdogEND
STARTbirdEND
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);