re = /START
(?:
(?: cat dog bird ) |
(?: cat | dog | bird )
)
END/mx
str = 'STARTcatdogbirdEND
STARTcatEND
STARTdogEND
STARTbirdEND
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end