$re = '/(?<=^፻.+)\b(?=\w.*፻$)/m';
$str = '፻this test works፻
፻this test does not work፻
this is a line that stays unchanged
this is a line that stays unchanged፻
፻this is a line that stays unchanged';
$subst = "፻";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;