re = /(?<=^፻.+)\b(?=\w.*፻$)/m
str = '፻this test works፻
፻this test does not work፻
this is a line that stays unchanged
this is a line that stays unchanged፻
፻this is a line that stays unchanged'
subst = '፻'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result