# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=^፻.+)\b(?=\w.*፻$)"
test_str = ("፻this test works፻\n"
"፻this test does not work፻\n"
"this is a line that stays unchanged\n"
"this is a line that stays unchanged፻\n"
"፻this is a line that stays unchanged")
subst = "፻"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.