#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<tipo_de_registro>\d)(?<codigo_de_retorno>\d)(?<literal_de_retorno>.{7})(?<codigo_de_servico>\d{2})(?<literal_de_servico>.{15})(?<agencia>\d{4})(?:\d{2})(?<conta>\d{5})(?<dac>\d{1})(?:.{8})(?<nome_da_empresa>.{30})(?<codigo_do_banco>\d{3})(?<nome_do_banco>.{15})(?<data_de_geracao>\d{6})(?<desidade>\d{5})(?<unidade_de_desidade>.{3})(?<numero_sequencial_arq_retorno>\d{5})(?<data_de_credito>\d{6})(?:.{275})(?<numero_sequencial>\d{6})"
Local $sString = "02RETORNO01COBRANCA 063700710369 MINASMAQUINAS ADM CONS LTDA 341BANCO ITAU S.A.26052101600BPI03305270521 000001maynewayent.com "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")