// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<tipo_de_registro>\d)(?<codigo_de_retorno>\d)(?<literal_de_retorno>.{7})(?<codigo_de_servico>\d{2})(?<literal_de_servico>.{15})(?<agencia>\d{4})(?:\d{2})(?<conta>\d{5})(?<dac>\d{1})(?:.{8})(?<nome_da_empresa>.{30})(?<codigo_do_banco>\d{3})(?<nome_do_banco>.{15})(?<data_de_geracao>\d{6})(?<desidade>\d{5})(?<unidade_de_desidade>.{3})(?<numero_sequencial_arq_retorno>\d{5})(?<data_de_credito>\d{6})(?:.{275})(?<numero_sequencial>\d{6})").unwrap();
let string = "02RETORNO01COBRANCA 063700710369 MINASMAQUINAS ADM CONS LTDA 341BANCO ITAU S.A.26052101600BPI03305270521 000001maynewayent.com ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}