# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<tipo_de_registro>\d)(?<codigo_de_retorno>\d)(?<literal_de_retorno>.{7})(?<codigo_de_servico>\d{2})(?<literal_de_servico>.{15})(?<agencia>\d{4})(?:\d{2})(?<conta>\d{5})(?<dac>\d{1})(?:.{8})(?<nome_da_empresa>.{30})(?<codigo_do_banco>\d{3})(?<nome_do_banco>.{15})(?<data_de_geracao>\d{6})(?<desidade>\d{5})(?<unidade_de_desidade>.{3})(?<numero_sequencial_arq_retorno>\d{5})(?<data_de_credito>\d{6})(?:.{275})(?<numero_sequencial>\d{6})"
test_str = "02RETORNO01COBRANCA 063700710369 MINASMAQUINAS ADM CONS LTDA 341BANCO ITAU S.A.26052101600BPI03305270521 000001maynewayent.com "
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.