import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "^(https?:\\/\\/)?[0-9a-z-_]*(\\.[0-9a-z-_]+)*(\\.[a-z]+)+(\\/[0-9a-z-_]*)*?\\/?$";
        final String string = "nearform.com\n"
	 + "graphql-hooks.com\n"
	 + "nearform.com/\n"
	 + "www.nearform.com\n"
	 + "www.nearform.com/\n"
	 + "http://nearform.com\n"
	 + "https://nearform.com/\n"
	 + "http://www.nearform.com\n"
	 + "https://github.nearform.com/graphql-hooks\n"
	 + "https://www.fastify.io/\n"
	 + "react-js.org\n";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}