$re = '/^(https?:\/\/)?[0-9a-z-_]*(\.[0-9a-z-_]+)*(\.[a-z]+)+(\/[0-9a-z-_]*)*?\/?$/im';
$str = 'nearform.com
graphql-hooks.com
nearform.com/
www.nearform.com
www.nearform.com/
http://nearform.com
https://nearform.com/
http://www.nearform.com
https://github.nearform.com/graphql-hooks
https://www.fastify.io/
react-js.org
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);