use strict;
my $str = 'nearform.com
graphql-hooks.com
nearform.com/
www.nearform.com
www.nearform.com/
http://nearform.com
https://nearform.com/
http://www.nearform.com
https://github.nearform.com/graphql-hooks
https://www.fastify.io/
react-js.org
';
my $regex = qr/^(https?:\/\/)?[0-9a-z-_]*(\.[0-9a-z-_]+)*(\.[a-z]+)+(\/[0-9a-z-_]*)*?\/?$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}