using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z0-9-]+)(\.[a-zA-Z]{2,5})?(\.[a-zA-Z]+$)";
string input = @"https://domain.com
https://subdomain.domain.com
https://www.sub.sub.subdomain.domain.com
http://sub.masterdomain.com.au
https://four.submains.new.domain.luxury.co.uk
https://www.globo.us/games/tap-zap-boom/
https://www.test.com/games/socce/index.html
https://google.com.br/services/index.php
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}