import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z0-9-]+)(\\.[a-zA-Z]{2,5})?(\\.[a-zA-Z]+$)";
final String string = "https://domain.com\n"
+ "https://subdomain.domain.com\n"
+ "https://www.sub.sub.subdomain.domain.com\n"
+ "http://sub.masterdomain.com.au\n"
+ "https://four.submains.new.domain.luxury.co.uk\n"
+ "https://www.globo.us/games/tap-zap-boom/\n"
+ "https://www.test.com/games/socce/index.html\n"
+ "https://google.com.br/services/index.php\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}