const regex = /([a-zA-Z0-9-]+)(\.[a-zA-Z]{2,5})?(\.[a-zA-Z]+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z0-9-]+)(\\.[a-zA-Z]{2,5})?(\\.[a-zA-Z]+$)', 'gm')
const str = `https://domain.com
https://subdomain.domain.com
https://www.sub.sub.subdomain.domain.com
http://sub.masterdomain.com.au
https://four.submains.new.domain.luxury.co.uk
https://www.globo.us/games/tap-zap-boom/
https://www.test.com/games/socce/index.html
https://google.com.br/services/index.php
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}