# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([a-zA-Z0-9-]+)(\.[a-zA-Z]{2,5})?(\.[a-zA-Z]+$)"
test_str = ("https://domain.com\n"
"https://subdomain.domain.com\n"
"https://www.sub.sub.subdomain.domain.com\n"
"http://sub.masterdomain.com.au\n"
"https://four.submains.new.domain.luxury.co.uk\n"
"https://www.globo.us/games/tap-zap-boom/\n"
"https://www.test.com/games/socce/index.html\n"
"https://google.com.br/services/index.php\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.