import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+?(?:\\.|\\?|\\!))(?:.+|\\n|\\s)";
final String string = "Deze kaart toont de werkelijke oppervlakte van elk land. ππΊοΈ\n\n"
+ "De wereldkaarten die we vaak zien, misleiden ons over de ware oppervlakte van landen. Deze afbeelding laat zien hoezeer onze perceptie kan afwijken van de werkelijke afmetingen van landen. ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}