re = /^(.+?(?:\.|\?|\!))(?:.+|\n|\s)/m
str = 'Deze kaart toont de werkelijke oppervlakte van elk land. ππΊοΈ
De wereldkaarten die we vaak zien, misleiden ons over de ware oppervlakte van landen. Deze afbeelding laat zien hoezeer onze perceptie kan afwijken van de werkelijke afmetingen van landen. '
# Print the match result
str.match(re) do |match|
puts match.to_s
end