import Foundation
let pattern = #"^(.+?(?:\.|\?|\!))(?:.+|\n|\s)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Deze kaart toont de werkelijke oppervlakte van elk land. ππΊοΈ
De wereldkaarten die we vaak zien, misleiden ons over de ware oppervlakte van landen. Deze afbeelding laat zien hoezeer onze perceptie kan afwijken van de werkelijke afmetingen van landen.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}