# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\s+)((?<=\s)[a-z]|^[a-z]).*?([A-Z]?(?<=[a-zA-Z0-9])[a-zA-Z0-9]+)/$2$3/g;t' <<< "do we have a Hashtag
 "