using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s+)((?<=\s)[a-z]|^[a-z]).*?([A-Z]?(?<=[a-zA-Z0-9])[a-zA-Z0-9]+)";
string substitution = @"$2$3";
string input = @"do we have a Hashtag
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}