const regex = /(\s+)((?<=\s)[a-z]|^[a-z]).*?([A-Z]?(?<=[a-zA-Z0-9])[a-zA-Z0-9]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s+)((?<=\\s)[a-z]|^[a-z]).*?([A-Z]?(?<=[a-zA-Z0-9])[a-zA-Z0-9]+)', 'g')
const str = `do we have a Hashtag
`;
const subst = `$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);