import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^/ # start of string and /\n"
+ "(?P<operation>buy|sell) #buy or sell\n"
+ "\\s+ # 1+ whitespaces\n"
+ "(?P<amount>\\d+) # 1+ digits\n"
+ "\\s+ # 1+ whitespaces\n"
+ "(?P<network>\\S+) # 1+ non-whitespaces\n"
+ "\\s+ @ \\s+ # 1+ whitespaces, @, 1+ whitespaces\n"
+ "(?P<rate>\\S+) # 1+ non-whitespaces\n"
+ "\\s+ # 1+ whitespaces\n"
+ "(?P<legal>\\S+) # 1+ non-whitespaces\n"
+ "\\s+ # 1+ whitespaces\n"
+ "(?P<cellphone>\\+?\\d(?:\\s?\\d)+) # optional +, digits with possible one whitespace in between each\n"
+ "(?: # non-capturing group start:\n"
+ " \\s+ (?P<email>[^\\s@]+@\\S+) # 1+ whitespaces, email\n"
+ ")? # non-capturing group end, optional due to ?\n"
+ "$ # end of string";
final String string = "/sell 2000 USDT @ 5.56 111.222.333-44 +123456789 mail@example.com\n\n"
+ "/sell 2000 USDT @ 5.56 111.222.333-44 +123456789";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}