$re = '/^/ # start of string and /
(?P<operation>buy|sell) #buy or sell
\s+ # 1+ whitespaces
(?P<amount>\d+) # 1+ digits
\s+ # 1+ whitespaces
(?P<network>\S+) # 1+ non-whitespaces
\s+ @ \s+ # 1+ whitespaces, @, 1+ whitespaces
(?P<rate>\S+) # 1+ non-whitespaces
\s+ # 1+ whitespaces
(?P<legal>\S+) # 1+ non-whitespaces
\s+ # 1+ whitespaces
(?P<cellphone>\+?\d(?:\s?\d)+) # optional +, digits with possible one whitespace in between each
(?: # non-capturing group start:
\s+ (?P<email>[^\s@]+@\S+) # 1+ whitespaces, email
)? # non-capturing group end, optional due to ?
$ # end of string/mx';
$str = '/sell 2000 USDT @ 5.56 111.222.333-44 +123456789 mail@example.com
/sell 2000 USDT @ 5.56 111.222.333-44 +123456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);